Topaz

SigPlus.Net Documentation

Topaz Namespace

Namespace hierarchy

Classes

Class | Description
SigPlusNET | Provides all the functionality required for customized capture and encryption of electronic handwritten biometric signatures.


SigPlusNET Class

For a list of all members of this type, see SigPlusNET Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Topaz.SigPlusNET

public class SigPlusNET : Control

Remarks

Provides all the functionality required for customized capture and encryption of electronic handwritten biometric signatures.

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Topaz

Assembly: SigPlusNET (in SigPlusNET.dll)

See Also

SigPlusNET Members | Topaz Namespace


SigPlusNET Members

SigPlusNET overview

Public Instance Constructors

SigPlusNET Constructor Initializes a new instance of the SigPlusNET class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from Control) | Gets the rectangle that represents the display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

AutoKeyFinish | Completes the auto key generation function.
AutoKeyStart | Initializes the automatic key generation function which derives a key from the data fed to it via SetAutoKeyData
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearSigWindow | Erases data either inside or outside of of sig window based on value of short inside.
ClearTablet | Clears the signature object of ink.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExportSigFile | Writes out a signature file in the Topaz image-free raw tablet data vector file format (.sig extension).
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetAnnotate | Returns current ASCII Annotation string.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDisplayAnnotate | Gets the current setting to display Annotation.
GetDisplayAnnotatePosX | Gets the current X position for the start of the Annotation String in the signature box.
GetDisplayAnnotatePosY | Gets the current Y position for the start of the Annotation String in the signature box.
GetDisplayAnnotateSize | Gets current Y size in pixels of the Annotation start in the signature box.
GetDisplayMode | NOT CURRENTLY IMPLEMENTED
GetDisplayPenWidth | Current pen ink width for the displayed signature in pixels.
GetDisplayRotate | Value of rotation on a 360 degree axis for signature display.
GetDisplayRotateSave | Gets state of DisplayRotateSave
GetDisplayTimeStamp | Gets the current setting for bean to display Time Stamp.
GetDisplayTimeStampPosX | Gets the current X position for the start of the Time Stamp String in the signature box.
GetDisplayTimeStampPosY | Gets the current Y position for the start of the Time Stamp String in the signature box.
GetDisplayTimeStampSize | Gets the Y size in pixels of the Time Stamp in the signature box.
GetDisplayWindowRes | Gets state of DisplayWindowRes.
GetEncryptionMode | Returns current EncryptionMode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetImageAnnotate | Gets the current setting for bean to display Annotation as it applies to the WriteImageFile method
GetImageAnnotatePosX | Gets the current X position for the start of the Annotation String in the signature box as it applies to the WriteImageFile method.
GetImageAnnotatePosY | Gets the current Y posiiton for the start of the Annotation String in the signature box as it applies to the WriteImageFile method.
GetImageAnnotateSize | Gets current Y size in pixels of the Annotation start in the signature box as it applies to the WriteImageFile method.
GetImageFileFormat | Returns the current setting of the image file format.
GetImagePenWidth | Gets current pen ink width as it applies to the WriteImageFile method.
GetImageTimeStamp | Gets the current setting for bean to display Time Stamp as it applies to the WriteImageFile method.
GetImageTimeStampPosX | Gets X position of the start of the Time Stamp in the signature box as it applies to the WriteImageFile method.
GetImageTimeStampPosY | Gets the current Y position in pixels for the start of the Time Stamp as it applies to the WriteImageFile method.
GetImageTimeStampSize | Gets the Y size in pixels of the Time Stamp in the signature box as it applies to the WriteImageFile method.
GetImageXSize | Gets the current width in X pixels of the image as it applies to the WriteImageFile method.
GetImageYSize | Gets the current height in Y pixels of the image as it applies to the WriteImageFile method.
GetJustifyMode | Gets the current justification mode- how the signature is sized and positioned in the signature box as well as when using the WriteImageFile method.
GetJustifyX | Gets the Justification X buffer size in pixels for display.
GetJustifyY | Gets the Justification Y buffers size in pixels for display.
GetKeyReceipt | Returns a 32 bit value that is uniquely derived from the key, it can be used to verify that a document has not been modified if the Auto key feature was used to generate the key.
GetKeyReceiptAscii | Returns the key receipt as a 8 character ascii hex string
GetKeyString | Provides hash of the encryption data in ASCII compatible format.
GetLCDCaptureMode | Gets the current LCD Capture Mode for the tablet.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetSaveSigInfo | Returns whether SaveSigInfo is active.
GetSigCompressionMode | Returns compression mode for signatures.
GetSigImage | Renders and returns a .NET Image, using ImageX and YSizes and Image pen width.
GetSigReceipt | Returns a 32 bit reciept similiar to the key receipt. Forms receipt by using the auto key generation algorithm on the signature file and the result can be used to verify that the signature has not been modified.
GetSigReceiptAscii | Same as GetKeyReceiptAscii, but for Sig receipt
GetSigString | SigString as ASCII hex string.
GetTabletBaudRate | Returns the current TabletBaudRate.
GetTabletComPort | Returns the current COM port setting.
GetTabletComTest | Gets current harware check mode, can be used to determine if tablet is connected or which port tablet is connected to.
GetTabletFilterPoints | Returns the current TabletFilterPoints.
GetTabletLogicalXSize | Returns current horizontal values used in representing signatures in Logical Tablet Coordinates.
GetTabletLogicalYSize | Returns current vertical values used in representing signatures in Logical Tablet Coordinates.
GetTabletResolution | Returns current TabletResolution.
GetTabletRotation | Gets the current orientation on a 360 degree axis for display of tablet data. The data in the sig representation is stored in the native tablet orientation.
GetTabletState | Indicates capture state of the tablet.
GetTabletTimingAdvance | Gets current TabletTimingAdvance.
GetTabletType | Gets TabletType value.
GetTabletXStart | Current X position in Logical Tablet Coordinates of the upper left hand corner of the component signature box.
GetTabletXStop | Returns the X position of the bottom right corner of the signature box in Logical Tablet Coordinates.
GetTabletYStart | Returns the Y position of the top left corner of the signature box in Logical Tablet Coordinates.
GetTabletYStop | Returns the Y position of the bottom right corner of the signature box in Logical Tablet Coordinates.
GetTimeStamp | Returns the time stamp string for the signature.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
ImportSigFile | Control Clears the current signature, reads in a signature file in the Topaz vector file format, and displays it.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
KeyPadAddHotSpot | Defines in software the location of a tablet HotSpot.
KeyPadClearHotSpotList | Clears the control's internal list of HotSpots.
KeyPadQueryHotSpot | Queries whether the specified HotSpot has been tapped by the user.
LCDClear | Erases the LCD display
LCDRefresh | Sends refresh command to tablet.
LCDSendCmdString | Method used to send commands to Topaz LCD Tablets. NOT CURRENTLY FOR DEVELOPER USE.
LCDSendGraphic | This writes an image to the LCD.
LCDSetWindow | Sets a signature window that restricts the ink of the SigPlus object to said window on the LCD itself
LCDStringHeight | Takes a string and a .NET font and hand back how tall the string is in pixels.
LCDStringWidth | Takes a string and a .NET font and hand back how wide the string is in pixels.
LCDWriteString | Used to write the image data to the LCD Display.
NumberOfTabletPoints | Returns the total number of points in the current signature and can be used to detect if a singature is present or not.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAnnotate | Sets Annotation string.
SetAutoKeyData | Adds data to the auto key generation function.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDisplayAnnotate | Sets the ASCII line character.
SetDisplayAnnotateData | Sets the component to display the Annotation string.
SetDisplayAnnotatePosX | Sets the X position in pixels of the start of the Annotation string in the signature box.
SetDisplayAnnotatePosY | Sets the Y position in pixels of the start of the Annotation string in the signature box.
SetDisplayAnnotateSize | Sets the Y size in pixels of the Annotation start of the Time Stamp in the signature box.
SetDisplayMode | NOT CURRENTLY IMPLEMENTED
SetDisplayPenWidth | Sets pen width for displayed signatures in pixels.
SetDisplayRotate | Sets mode allowing signature rotation ofter capture.
SetDisplayRotateSave | Sets mode allowing signature rotation and the save of signature in rotated format after capture.
SetDisplayTimeStamp | Sets the component to display the Time Stamp.
SetDisplayTimeStampData | Sets display screen info for Time and Date stamp.
SetDisplayTimeStampPosX | Sets the X position in pixels of the start of the Time Stamp in the signature box.
SetDisplayTimeStampPosY | Sets the Y position in pixels of the start of the Time Stamp in the signature box.
SetDisplayTimeStampSize | Sets the Y size in pixels of the Time Stamp in the signature box.
SetDisplayWindowRes | Sets mode which renders signatures in lower (screen) resolution for compatibility in printing directly from VB.
SetEncryptionMode | Sets the encryption mode used for capturing signatures.
SetImageAnnotate | Sets whether or not the annotation is being displayed as it applies to the WriteImageFile method.
SetImageAnnotateData | Sets the component to display the Annotation string as it applies to the WriteImageFile method.
SetImageAnnotatePosX | Sets the X position in pixels of the start of the Annotation string as it applies to the WriteImageFile method.
SetImageAnnotatePosY | Sets the Y position in pixels of the start of the Annotation string as it applies to the WriteImageFile method.
SetImageAnnotateSize | Sets the size in pixels of the Annotation as it applies to the WriteImageFile method.
SetImageFileFormat | Sets the current format to use for Image files. The default is .BMP.
SetImagePenWidth | Sets pen width for the image in pixels as it applies to the WriteImageFile method.
SetImageTimeStamp | Sets the component to display the Time Stamp as it applies to the WriteImageFile method.
SetImageTimeStampData | Sets display screen info for Time and Date stamp.
SetImageTimeStampPosX | Sets the X position in pixels of the start of the Time Stamp as it applies to the WriteImageFile method.
SetImageTimeStampPosY | Sets the Y position in pixels of the start of the Time Stamp as it applies to the WriteImageFile method.
SetImageTimeStampSize | Sets the size in pixels of the Time Stamp as it applies to the WriteImageFile method.
SetImageXSize | Sets the number of X pixels in the image provided by the WriteImageFile method.
SetImageYSize | Sets the number of Y pixels in the image provided by the WriteImageFile method.
SetJustifyMode | Sets the current justification mode- how the signature is sized and positioned in the signature box as well as when using the WriteImageFile method.
SetJustifyX | Sets the buffer size in Logical Tablet Coordinates of "dead space" of left and right edge of SigPlus object if JustifyMode is 1-5. This method functions for both the signature box as well as when using the WriteImageFile method.
SetJustifyY | Sets the buffer size in Logical Tablet Coordinates of "dead space" of top and bottom edge of SigPlus object if JustifyMode is 1-5. This method functions for both the signature box as well as when using the WriteImageFile method.
SetKeyString | Sets the Key String into the SigPlus component
SetLCDCaptureMode | Sets the current LCD Capture Mode for the tablet.
SetSaveSigInfo | Enables/Disables the saving of TimeStamp and Annotate data in the signature.
SetSigCompressionMode | Sets the current compression mode for signatures.
SetSigString | Sets the signature string into the SigPlus component.
SetSigWindow | This function sets a window in the logical tablet space that restricts the operation of some functions to the specified window.
SetTabletBaudRate | Sets the baud rate for the tablet.
SetTabletComPort | Sets the COM port to use.
SetTabletComTest | Sets hardware test mode.
SetTabletFilterPoints | Sets the TabletFilterPoints.
SetTabletLogicalXSize | Sets the Range of horizontal values to be used in representing signatures.
SetTabletLogicalYSize | Sets the range of vertical values to be used in representing signatures.
SetTabletResolution | Sets tablet hardware resolution.
SetTabletRotation | Sets the orientation on a 360 degree axis for display of tablet data.
SetTabletState | Opens port to enable signature capture.
SetTabletTimingAdvance | Sets the TabletTimingAdvance.
SetTabletType | Determines if the tablet will accept data from a com port, WinTab driver, USB driver or other method of data input.
SetTabletXStart | Sets the X position of the top left corner of the signature box in Logical Tablet Coordinates.
SetTabletXStop | Sets the X position of the bottom right corner of the signature box in Logical Tablet Coordinates.
SetTabletYStart | Sets the Y position of the top left corner of the signature box in Logical Tablet Coordinates.
SetTabletYStop | Sets the Y position of the bottom right corner of the signature box in Logical Tablet Coordinates.
SetTimeStamp | Sets the Time Stamp for the signature.
Show (inherited from Control) | Displays the control to the user.
Sleep |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
WriteImageFile | The control will write out a signature file in the current Image file format.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Control) | Gets the required creation parameters when the control handle is created.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Control) | Gets the default size of the control.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
Finalize |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTimedEvent |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also

SigPlusNET Class | Topaz Namespace


SigPlusNET Constructor

Initializes a new instance of the SigPlusNET class.

public SigPlusNET();

See Also


SigPlusNET Methods

The methods of the SigPlusNET class are listed below. For a complete list of SigPlusNET class members, see the SigPlusNET Members topic.

Public Instance Methods

AutoKeyFinish | Completes the auto key generation function.
AutoKeyStart | Initializes the automatic key generation function which derives a key from the data fed to it via SetAutoKeyData.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
ClearSigWindow | Erases data either inside or outside of of sig window based on value of short inside.
ClearTablet | Clears the signature object of ink.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExportSigFile | Writes out a signature file in the Topaz image-free raw tablet data vector file format (.sig extension).
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetAnnotate | Returns current ASCII Annotation string.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetDisplayAnnotate | Gets the current setting to display Annotation.
GetDisplayAnnotatePosX | Gets the current X position for the start of the Annotation String in the signature box.
GetDisplayAnnotatePosY | Gets the current Y position for the start of the Annotation String in the signature box.
GetDisplayAnnotateSize | Gets current Y size in pixels of the Annotation start in the signature box.
GetDisplayMode | NOT CURRENTLY IMPLEMENTED
GetDisplayPenWidth | Current pen ink width for the displayed signature in pixels.
GetDisplayRotate | Value of rotation on a 360 degree axis for signature display.
GetDisplayRotateSave | Gets state of DisplayRotateSave
GetDisplayTimeStamp | Gets the current setting for component to display Time Stamp.
GetDisplayTimeStampPosX | Gets the current X position for the start of the Time Stamp String in the signature box.
GetDisplayTimeStampPosY | Gets the current Y position for the start of the Time Stamp String in the signature box.
GetDisplayTimeStampSize | Gets the Y size in pixels of the Time Stamp in the signature box.
GetDisplayWindowRes | Gets state of DisplayWindowRes.
GetEncryptionMode | Returns current EncryptionMode.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetImageAnnotate | Gets the current setting for component to display Annotation as it applies to the WriteImageFile method
GetImageAnnotatePosX | Gets the current X position for the start of the Annotation String in the signature box as it applies to the WriteImageFile method.
GetImageAnnotatePosY | Gets the current Y posiiton for the start of the Annotation String in the signature box as it applies to the WriteImageFile method.
GetImageAnnotateSize | Gets current Y size in pixels of the Annotation start in the signature box as it applies to the WriteImageFile method.
GetImageFileFormat | Returns the current setting of the image file format.
GetImagePenWidth | Gets current pen ink width as it applies to the WriteImageFile method.
GetImageTimeStamp | Gets the current setting for component to display Time Stamp as it applies to the WriteImageFile method.
GetImageTimeStampPosX | Gets X position of the start of the Time Stamp in the signature box as it applies to the WriteImageFile method.
GetImageTimeStampPosY | Gets the current Y position in pixels for the start of the Time Stamp as it applies to the WriteImageFile method.
GetImageTimeStampSize | Gets the Y size in pixels of the Time Stamp in the signature box as it applies to the WriteImageFile method.
GetImageXSize | Gets the current width in X pixels of the image as it applies to the WriteImageFile method.
GetImageYSize | Gets the current height in Y pixels of the image as it applies to the WriteImageFile method.
GetJustifyMode | Gets the current justification mode- how the signature is sized and positioned in the signature box as well as when using the WriteImageFile method.
GetJustifyX | Gets the Justification X buffer size in pixels for display.
GetJustifyY | Gets the Justification Y buffers size in pixels for display.
GetKeyReceipt | Returns a 32 bit value that is uniquely derived from the key, it can be used to verify that a document has not been modified if the Auto key feature was used to generate the key.
GetKeyReceiptAscii | Returns the key receipt as a 8 character ascii hex string
GetKeyString | Provides hash of the encryption data in ASCII compatible format.
GetLCDCaptureMode | Gets the current LCD Capture Mode for the tablet.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetSaveSigInfo | Returns whether SaveSigInfo is active.
GetSigCompressionMode | Returns compression mode for signatures.
GetSigImage | Renders and returns a .NET Image, using ImageX and YSizes and Image pen width.
GetSigReceipt | Returns a 32 bit reciept similiar to the key receipt. Forms receipt by using the auto key generation algorithm on the signature file and the result can be used to verify that the signature has not been modified.
GetSigReceiptAscii | Same as GetKeyReceiptAscii, but for Sig receipt
GetSigString | SigString as ASCII hex string.
GetTabletBaudRate | Returns the current TabletBaudRate.
GetTabletComPort | Returns the current COM port setting.
GetTabletComTest | Gets current harware check mode, can be used to determine if tablet is connected or which port tablet is connected to.
GetTabletFilterPoints | Returns the current TabletFilterPoints.
GetTabletLogicalXSize | Returns current horizontal values used in representing signatures in Logical Tablet Coordinates.
GetTabletLogicalYSize | Returns current vertical values used in representing signatures in Logical Tablet Coordinates.
GetTabletResolution | Returns current TabletResolution.
GetTabletRotation | Gets the current orientation on a 360 degree axis for display of tablet data. The data in the sig representation is stored in the native tablet orientation.
GetTabletState | Indicates capture state of the tablet.
GetTabletTimingAdvance | Gets current TabletTimingAdvance
GetTabletType | Gets TabletType value.
GetTabletXStart | Current X position in Logical Tablet Coordinates of the upper left hand corner of the component signature box.
GetTabletXStop | Returns the X position of the bottom right corner of the signature box in Logical Tablet Coordinates.
GetTabletYStart | Returns the Y position of the top left corner of the signature box in Logical Tablet Coordinates.
GetTabletYStop | Returns the Y position of the bottom right corner of the signature box in Logical Tablet Coordinates.
GetTimeStamp | Returns the time stamp string for the signature.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
ImportSigFile | Control Clears the current signature, reads in a signature file in the Topaz vector file format, and displays it.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
KeyPadAddHotSpot | Defines in software the location of a tablet HotSpot.
KeyPadClearHotSpotList | Clears the control's internal list of HotSpots.
KeyPadQueryHotSpot | Queries whether the specified HotSpot has been tapped by the user.
LCDClear | Erases the LCD display
LCDRefresh | Sends refresh command to tablet.
LCDSendCmdString | Method used to send commands to Topaz LCD Tablets. NOT CURRENTLY FOR DEVELOPER USE.
LCDSendGraphic | This writes an image to the LCD.
LCDSetWindow | Sets a signature window that restricts the ink of the SigPlus object to said window on the LCD itself
LCDStringHeight | Takes a string and a .NET font and hand back how tall the string is in pixels.
LCDStringWidth | Takes a string and a .NET font and hand back how wide the string is in pixels.
LCDWriteString | Used to write the image data to the LCD Display.
NumberOfTabletPoints | Returns the total number of points in the current signature and can be used to detect if a singature is present or not.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAnnotate | Sets Annotation string.
SetAutoKeyData | Adds data to the auto key generation function.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDisplayAnnotate | Sets the ASCII line character.
SetDisplayAnnotateData | Sets the component to display the Annotation string.
SetDisplayAnnotatePosX | Sets the X position in pixels of the start of the Annotation string in the signature box.
SetDisplayAnnotatePosY | Sets the Y position in pixels of the start of the Annotation string in the signature box.
SetDisplayAnnotateSize | Sets the Y size in pixels of the Annotation start of the Time Stamp in the signature box.
SetDisplayMode | NOT CURRENTLY IMPLEMENTED
SetDisplayPenWidth | Sets pen width for displayed signatures in pixels.
SetDisplayRotate | Sets mode allowing signature rotation ofter capture.
SetDisplayRotateSave | Sets mode allowing signature rotation and the save of signature in rotated format after capture.
SetDisplayTimeStamp | Sets the component to display the Time Stamp.
SetDisplayTimeStampData | Sets display screen info for Time and Date stamp.
SetDisplayTimeStampPosX | Sets the X position in pixels of the start of the Time Stamp in the signature box.
SetDisplayTimeStampPosY | Sets the Y position in pixels of the start of the Time Stamp in the signature box.
SetDisplayTimeStampSize | Sets the Y size in pixels of the Time Stamp in the signature box.
SetDisplayWindowRes | Sets mode which renders signatures in lower (screen) resolution for compatibility in printing directly from VB.
SetEncryptionMode | Sets the encryption mode used for capturing signatures.
SetImageAnnotate | Sets whether or not the annotation is being displayed as it applies to the WriteImageFile method.
SetImageAnnotateData | Sets the component to display the Annotation string as it applies to the WriteImageFile method.
SetImageAnnotatePosX | Sets the X position in pixels of the start of the Annotation string as it applies to the WriteImageFile method.
SetImageAnnotatePosY | Sets the Y position in pixels of the start of the Annotation string as it applies to the WriteImageFile method.
SetImageAnnotateSize | Sets the size in pixels of the Annotation as it applies to the WriteImageFile method.
SetImageFileFormat | Sets the current format to use for Image files. The default is .BMP.
SetImagePenWidth | Sets pen width for the image in pixels as it applies to the WriteImageFile method.
SetImageTimeStamp | Sets the component to display the Time Stamp as it applies to the WriteImageFile method.
SetImageTimeStampData | Sets display screen info for Time and Date stamp.
SetImageTimeStampPosX | Sets the X position in pixels of the start of the Time Stamp as it applies to the WriteImageFile method.
SetImageTimeStampPosY | Sets the Y position in pixels of the start of the Time Stamp as it applies to the WriteImageFile method.
SetImageTimeStampSize | Sets the size in pixels of the Time Stamp as it applies to the WriteImageFile method.
SetImageXSize | Sets the number of X pixels in the image provided by the WriteImageFile method.
SetImageYSize | Sets the number of Y pixels in the image provided by the WriteImageFile method.
SetJustifyMode | Sets the current justification mode- how the signature is sized and positioned in the signature box as well as when using the WriteImageFile method.
SetJustifyX | Sets the buffer size in Logical Tablet Coordinates of "dead space" of left and right edge of SigPlus object if JustifyMode is 1-5. This method functions for both the signature box as well as when using the WriteImageFile method.
SetJustifyY | Sets the buffer size in Logical Tablet Coordinates of "dead space" of top and bottom edge of SigPlus object if JustifyMode is 1-5. This method functions for both the signature box as well as when using the WriteImageFile method.
SetKeyString | Sets the Key String into the SigPlus component
SetLCDCaptureMode | Sets the current LCD Capture Mode for the tablet.
SetSaveSigInfo | Enables/Disables the saving of TimeStamp and Annotate data in the signature.
SetSigCompressionMode | Sets the current compression mode for signatures.
SetSigString | Sets the signature string into the component.
SetSigWindow | This function sets a window in the logical tablet space that restricts the operation of some functions to the specified window.
SetTabletBaudRate | Sets the baud rate for the tablet.
SetTabletComPort | Sets the COM port to use.
SetTabletComTest | Sets hardware test mode.
SetTabletFilterPoints | Sets the TabletFilterPoints.
SetTabletLogicalXSize | Sets the Range of horizontal values to be used in representing signatures.
SetTabletLogicalYSize | Sets the range of vertical values to be used in representing signatures.
SetTabletResolution | Sets tablet hardware resolution.
SetTabletRotation | Sets the orientation on a 360 degree axis for display of tablet data.
SetTabletState | Opens port to enable signature capture.
SetTabletTimingAdvance | Sets the TabletTimingAdvance.
SetTabletType | Determines if the tablet will accept data from a com port, WinTab driver, USB driver or other method of data input.
SetTabletXStart | Sets the X position of the top left corner of the signature box in Logical Tablet Coordinates.
SetTabletXStop | Sets the X position of the bottom right corner of the signature box in Logical Tablet Coordinates.
SetTabletYStart | Sets the Y position of the top left corner of the signature box in Logical Tablet Coordinates.
SetTabletYStop | Sets the Y position of the bottom right corner of the signature box in Logical Tablet Coordinates.
SetTimeStamp | Sets the Time Stamp for the signature.
Show (inherited from Control) | Displays the control to the user.
Sleep |
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
WriteImageFile | The control will write out a signature file in the current Image file format.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and optionally releases the managed resources.
Finalize |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from Control) | Raises the Layout event.
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from Control) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnTimedEvent |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Control) | Raises the VisibleChanged event.
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Control) | Performs the work of scaling the entire control and any child controls.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Control) | Processes Windows messages.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

See Also


SigPlusNET.AutoKeyFinish Method

public void AutoKeyFinish();

Remarks

Completes the auto key generation function.

See Also


SigPlusNET.AutoKeyStart Method

public void AutoKeyStart();

Remarks

Initializes the automatic key generation function which derives a key from the data fed to it via SetAutoKeyData (string), when all data is input then AutoKeyFinish () must be called to compete key generation. If the AutoKeyStart method is not called, then the SetAutoKeyData method is used to pass the path to a file, which is then used to encrypt the signature, when AutoKeyStart is called then SetAutoKeyData is used to pass in string literals as data.

See Also


SigPlusNET.ClearSigWindow Method

public void ClearSigWindow(
short Inside
);

Remarks

Erases data either inside or outside of of sig window based on value of short inside

Parameters

inside-if=0 then signature data is erased (in window), if =1 then data outside sig window is erased.

See Also


SigPlusNET.ClearTablet Method

public void ClearTablet();

Remarks

Clears the signature object of ink

See Also


SigPlusNET.ExportSigFile Method

public bool ExportSigFile(
string FileName
);

Remarks

Writes out a signature file in the Topaz image-free raw tablet data vector file format (.sig extension)

Paramters

FileName- Name of file

Return Value

True if successful, false if not succesful

See Also


SigPlusNET.Finalize Method

protected override void Finalize();

See Also


SigPlusNET.GetAnnotate Method

public string GetAnnotate();

Return Value

Returns current ASCII Annotation string

See Also


SigPlusNET.GetDisplayAnnotate Method

public bool GetDisplayAnnotate();

Remarks

Gets the current setting to display Annotation

Return Value

True if Annotation is displayed, false if not displayed

See Also


SigPlusNET.GetDisplayAnnotatePosX Method

public int GetDisplayAnnotatePosX();

Remarks

Gets the current X position for the start of the Annotation String in the signature box

Return Value

X position for start of the Annotation string, if 0 then text is positioned 5% in from right side of signature box

See Also


SigPlusNET.GetDisplayAnnotatePosY Method

public int GetDisplayAnnotatePosY();

Remarks

Gets the current Y position for the start of the Annotation String in the signature box

Return Value

Y position for the start of the Annotation String, if 0 then text is positioned 5% in from bottom edge of signature box

See Also


SigPlusNET.GetDisplayAnnotateSize Method

public int GetDisplayAnnotateSize();

Remarks

Gets current Y size in pixels of the Annotation start in the signature box.

Return Value

Text size of the Annotation in pixels, if 0 then the text size is 7.5% of the Y size of the signature box

See Also


SigPlusNET.GetDisplayMode Method

public int GetDisplayMode();

Remark

NOT CURRENTLY IMPLEMENTED

See Also


SigPlusNET.GetDisplayPenWidth Method

public int GetDisplayPenWidth();

Return Value

Current pen ink width for the displayed signature in pixels.

See Also


SigPlusNET.GetDisplayRotate Method

public bool GetDisplayRotate();

Return Value

Value of rotation on a 360 degree axis for signature display.

See Also


SigPlusNET.GetDisplayRotateSave Method

public bool GetDisplayRotateSave();

Remarks

Gets state of DisplayRotateSave.Can be used to rotate and then save in rotated format, signatures after capture, ifthe signature was accidentally taken in a rotated orientation during signature capture. Normally, so change the tablet orientation during capture, only the TabletRotation property is used.

Retun Value

TRUE DisplayRotateSave mode = active, FALSE DisplayRotateSave mode = inactive

See Also


SigPlusNET.GetDisplayTimeStamp Method

public bool GetDisplayTimeStamp();

Remarks

Gets the current setting for bean to display Time Stamp

Return Value

True if Time Stamp is displayed, False if not displayed

See Also


SigPlusNET.GetDisplayTimeStampPosX Method

public int GetDisplayTimeStampPosX();

Remarks

Gets the current X position for the start of the Time Stamp String in the signature box.

Return Value

X value in pixels relative to the left edge, if 0 then 5% in from left side of signature box

See Also


SigPlusNET.GetDisplayTimeStampPosY Method

public int GetDisplayTimeStampPosY();

Remarks

Gets the current Y position for the start of the Time Stamp String in the signature box.

Return Value

Y value in pixels relative to the bottom edge, if 0 then 5% from bottom edge of signature box.

See Also


SigPlusNET.GetDisplayTimeStampSize Method

public int GetDisplayTimeStampSize();

Remarks

Gets the Y size in pixels of the Time Stamp in the signature box.

Return Value

Time Stamp size in pixels, if 0 then text size is 7.5% of y size of signature box.

See Also


SigPlusNET.GetDisplayWindowRes Method

public bool GetDisplayWindowRes();

Remarks

Gets state of DisplayWindowRes.

Return Value

TRUE DisplayWindowRes mode = active, FALSE DisplayWindowRes mode = inactive.

See Also


SigPlusNET.GetEncryptionMode Method

public int GetEncryptionMode();

Remarks

Returns current EncryptionMode

Return Value

Numeric value of encryption mode, 0= no encryption, 1= medium encryption, 2=higher security encryption mode

See Also


SigPlusNET.GetImageAnnotate Method

public bool GetImageAnnotate();

Remarks

Gets the current setting for bean to display Annotation as it applies to the WriteImageFile method

Return Value

True if Annotation is displayed, false if not displayed for Image.

See Also


SigPlusNET.GetImageAnnotatePosX Method

public int GetImageAnnotatePosX();

Remarks

Gets the current X poistion for the start of the Annotation String in the signature box as it applies to the WriteImageFile method.

Return Value

X position for start of the Annotation string, if 0 then text is positioned 5% in from right side of signature box for Image.

See Also


SigPlusNET.GetImageAnnotatePosY Method

public int GetImageAnnotatePosY();

Remarks

Gets the current Y posiiton for the start of the Annotation String in the signature box as it applies to the WriteImageFile method.

Return Value

Y position for the start of the Annotation String, if 0 then test is positioned 5% in from bottom edge of signature box.

See Also


SigPlusNET.GetImageAnnotateSize Method

public int GetImageAnnotateSize();

Remarks

Gets current Y size in pixels of the Annotation start in the signature box as it applies to the WriteImageFile method.

Return Value

Text size of the Annotation in pixels, if 0 then test size is 7.5% of the Y size of the signature box.

See Also


SigPlusNET.GetImageFileFormat Method

public int GetImageFileFormat();

Remarks

Returns the current setting of the image file format.

Return Value

Integer value of image file type as listed for the SetImageFileFormat method.

See Also


SigPlusNET.GetImagePenWidth Method

public int GetImagePenWidth();

Remarks

Gets current pen ink width as it applies to the WriteImageFile method.

Return Value

Pen ink width for Image

See Also


SigPlusNET.GetImageTimeStamp Method

public bool GetImageTimeStamp();

Remarks

Gets the current setting for bean to display Time Stamp as it applies to the WriteImageFile method.

Return Value

True if Time Stamp is displayed, False if not displayed for Image

See Also


SigPlusNET.GetImageTimeStampPosX Method

public int GetImageTimeStampPosX();

Remarks

Gets X position of the start of the Time Stamp in the signature box as it applies to the WriteImageFile method.

Return Value

X value in pixels relative to the left edge, if 0 then 5% in from the left side of signature box.

See Also


SigPlusNET.GetImageTimeStampPosY Method

public int GetImageTimeStampPosY();

Remarks

Gets the current Y position in pixels for the start of the Time Stamp as it applies to the WriteImageFile method.

Return Value

Y value in pixels relative to the left edge, if 0 then 5% from the bottom edge of the signature box.

See Also


SigPlusNET.GetImageTimeStampSize Method

public int GetImageTimeStampSize();

Remarks

Gets the Y size in pixels of the Time Stamp in the signature box as it applies to the WriteImageFile method.

Return Value

Time Stamp size in pixels, if 0 then text size is 7.5% of Y size of signature box.

See Also


SigPlusNET.GetImageXSize Method

public int GetImageXSize();

Remarks

Gets the current width in X pixels of the image as it applies to the WriteImageFile method.

Return Value

Number of X pixels of image.

See Also


SigPlusNET.GetImageYSize Method

public int GetImageYSize();

Remarks

Gets the current height in Y pixels of the image as it applies to the WriteImageFile method.

Return Value

Number of Y pixels in Image height.

See Also


SigPlusNET.GetJustifyMode Method

public int GetJustifyMode();

Remarks

Gets the current justification mode- how the signature is sized and positioned in the signature box as well as when using the WriteImageFile method.

Return Value

Justification mode, 0-normal no justification, 1-justify and zoom signature (upper left corner) 2-justify and zoom signature (upper right corner) 3-justify and zoom signature (lower left corner) 4-justify and zoom signature (lower right corner) 5-justify and zoom signature (center of control).

See Also


SigPlusNET.GetJustifyX Method

public int GetJustifyX();

Return Value

Justification X buffer size in pixels for display.

See Also


SigPlusNET.GetJustifyY Method

public int GetJustifyY();

Return Value

Justification Y buffers size in pixels for display.

See Also


SigPlusNET.GetKeyReceipt Method

public int GetKeyReceipt();

Remarks

Returns a 32 bit value that is uniquely derived from the key, it can be used to verify that a document has not been modified if the Auto key feature was used to generate the key.

Return Value

32 bit binary receipt.

See Also


SigPlusNET.GetKeyReceiptAscii Method

public string GetKeyReceiptAscii();

Remarks

Returns the key receipt as a 8 character ascii hex string.

Return Value

The Ascii string.

See Also


SigPlusNET.GetKeyString Method

public string GetKeyString();

Remarks

Provides hash of the encryption data in ASCII compatible format.

Return Value

Hash of encryption data.

See Also


SigPlusNET.GetLCDCaptureMode Method

public int GetLCDCaptureMode();

Remarks

Gets the current LCD Capture Mode for the tablet.

Return Value

Mode the LCD is set to capture signatures in, Mode 0 no LCD commands are sent to the tablet, Mode 1-sets capture mode to be active with Autoerase in the tablet, Mode 2-sets the tablet to persistent ink capture without autoerase, Mode 3-signature ink is displayed inverted on a suitable dark background set using the Graphic functions.

See Also


SigPlusNET.GetSaveSigInfo Method

public bool GetSaveSigInfo();

Return Value

True if SigInfo is enabled, False if disabled

See Also


SigPlusNET.GetSigCompressionMode Method

public int GetSigCompressionMode();

Remarks

Returns compression mode for signatures.

Return Value

Mode for compression of signature, where 0= no compression, 1= lossless compression with compacted data format, 2-8= compression ratio of signature stored in in .sig file where 2=1KB typ, 4=500 byte typ, and 8=250 byte typ. Topaz Systems does not recommend compressing beyond setting 1 unless size is more important than signature quality.

See Also


SigPlusNET.GetSigImage Method

public Image GetSigImage();

Remarks

Renders and returns a .NET Image, using ImageX and YSizes and Image pen width. The returned image can use the SaveAs method in the Image class to save the image into a number of supported formats. Such as jpg, tif, bmp, png, etc.

Retun Value

A .NET Image

See Also


SigPlusNET.GetSigReceipt Method

public int GetSigReceipt();

Remarks

Returns a 32 bit reciept similiar to the key receipt. Forms receipt by using the auto key generation algorithm on the signature file and the result can be used to verify that the signature has not been modified.

Return Value

32 bit binary receipt.

See Also


SigPlusNET.GetSigReceiptAscii Method

public string GetSigReceiptAscii();

Remarks

Same as GetKeyReceiptAscii, but for Sig receipt.

Return Value

The Ascii string

See Also


SigPlusNET.GetSigString Method

public string GetSigString();

Return Value

SigString as ASCII hex string.

See Also


SigPlusNET.GetTabletBaudRate Method

public int GetTabletBaudRate();

Return Value

Current TabletBaudRate

See Also


SigPlusNET.GetTabletComPort Method

public int GetTabletComPort();

Return Value

Current COM port setting.

See Also


SigPlusNET.GetTabletComTest Method

public int GetTabletComTest();

Remarks

Gets current harware check mode, can be used to determine if tablet is connected or which port tablet is connected to.

Return Value

Current hardware check mode, True if active, False if not active.

See Also


SigPlusNET.GetTabletFilterPoints Method

public int GetTabletFilterPoints();

Return Value

Current TabletFilterPoints

See Also


SigPlusNET.GetTabletLogicalXSize Method

public int GetTabletLogicalXSize();

Return Value

Current horizontal values used in representing signatures in Logical Tablet Coordinates.

See Also


SigPlusNET.GetTabletLogicalYSize Method

public int GetTabletLogicalYSize();

Return Value

Current vertical values used in representing signatures in Logical Tablet Coordinates

See Also


SigPlusNET.GetTabletResolution Method

public int GetTabletResolution();

Return Value

Current TabletResolution

See Also


SigPlusNET.GetTabletRotation Method

public int GetTabletRotation();

Remarks

Gets the current orientation on a 360 degree axis for display of tablet data. The data in the sig representation is stored in the native tablet orientation.

Return Value

Current tablet orientation.

See Also


SigPlusNET.GetTabletState Method

public int GetTabletState();

Remarks

Indicates capture state of the tablet.

Return Value

Value of 1 enables the component to access the selected COM or USB port and access the tablet for signature capture, 0 disables the tablet for capture.

See Also


SigPlusNET.GetTabletTimingAdvance Method

public int GetTabletTimingAdvance();

Return Value

Current TabletTimingAdvance

See Also


SigPlusNET.GetTabletType Method

public int GetTabletType();

Remarks

Gets TabletType value.

Return Value

Integer value of TabletType, see SetTabletType.

See Also


SigPlusNET.GetTabletXStart Method

public int GetTabletXStart();

Returnn Value

Current X position in Logical Tablet Coordinates of the upper left hand corner of the component signature box.

See Also


SigPlusNET.GetTabletXStop Method

public int GetTabletXStop();

Remarks

Gets the X pos in Logical Tablet Coordinates of the right most X pixel.

Return Value

The X pos of the right most pixel.

See Also


SigPlusNET.GetTabletYStart Method

public int GetTabletYStart();

Remarks

Gets the current Y pos in Logical Tablet Coordinates of the top most pixel.

Return Value

The Y pos of the top most pixel.

See Also


SigPlusNET.GetTabletYStop Method

public int GetTabletYStop();

Remarks

Gets the current Y pos in Logical Tablet Coordinates of the bottom most pixel.

Return Value

Y pos of bottom most pixel.

See Also


SigPlusNET.GetTimeStamp Method

public string GetTimeStamp();

Remarks

Gets the current Time Stamp string for the signature.

Return Value

ASCII new line character.

See Also


SigPlusNET.ImportSigFile Method

public bool ImportSigFile(
string FileName
);

Remarks

Clears the current signature, read in a signature file in the Topaz vector file format, and display it.

Parameters

FileName-Contains the path and filename that is to be read from.

Return Value

True if successful, False if not succesful.

See Also


SigPlusNET.KeyPadAddHotSpot Method

public void KeyPadAddHotSpot(
short KeyCode,
short CoordToUse,
short XPos,
short YPos,
short XSize,
short YSize
);

Remarks

Defines in software the location of a tablet HotSpot which is used by the developer to detect user pen taps.

Parameters

KeyCode-Integer value defining the HotSpot.

CoordToUse-Coordinate system used for this HotSpot.

XPos-Location (upper left- 0,0)

YPos-Same

XSize-X size in pixels.

YSize-Y size in pixels.

See Also


SigPlusNET.KeyPadClearHotSpotList Method

public void KeyPadClearHotSpotList();

Remarks

Clears the controls internal list of HotSpots created using KeyPadAddHotSpot.

See Also


SigPlusNET.KeyPadQueryHotSpot Method

public short KeyPadQueryHotSpot(
short KeyCode
);

Remarks

Queries whether the specified HotSpot has been tapped by the user. Returns a true if the control contains data that is within the definition of the keyCode on the tablet.

Paramters

KeyCode-Mapped Logical Tablet Coordinates.

Return Value

Number of points within the keyCode definition.

See Also


SigPlusNET.LCDClear Method

public void LCDClear();

Remarks

Erases the LCD display easily by calling LCDRefresh to do it

See Also


SigPlusNET.LCDRefresh Method

public bool LCDRefresh(
int Mode,
int XPos,
int YPos,
int XSize,
int YSize
);

Remarks

Sends tablet a refresh command with 4 possible modes. Mode 0-Clear, display is cleared at the specified location. Mode 1-Complement, complements display at the specifiedd location. Mode 2-WriteOpaque, transfers contents of the background memory to the LCD display, overwriting the content of the LCD display. Mode 3-WriteTransparent, transfers contents of the background memor in the tablebt to the LCD display and combined in the contents of the LCD display.

Parameters

Mode-Defined as above (0-4)

XPos-Location in LCD Coordinates (upper left-0,0)

YPos-Same

XSize-X size in LCD pixels

YSize-Y size in LCD pixels

Return Value

True if checksum received and verified, False if no or incorrect checksum received from tablet.

See Also


SigPlusNET.LCDSendCmdString Method

public int LCDSendCmdString(
string CmdStr,
int ReturnCount,
string Result,
int TimeOut
);

Remarks

Method used to send commands to Topaz LCD Tablets. NOT CURRENTLY FOR DEVELOPER USE.

See Also


SigPlusNET.LCDSendGraphic Method

public bool LCDSendGraphic(
int Dest,
int Mode,
int XPos,
int YPos,
Bitmap BitmapData
);

Remarks

This writes an image to the LCD by taking a .NET Drawing::Bitmap as the source for the image.

Parameters

Dest- 0=Foreground,1=Background memory in tablet

Mode-0-3 as defined in LCDWriteBitmap

XPos-Location in LCD coordinates (upper left- 0,0)

YPos-Same

BitmapData-Source for rendered image

Return Value

True if succesful, False if not.

See Also


SigPlusNET.LCDSetWindow Method

public bool LCDSetWindow(
int XPos,
int YPos,
int XSize,
int YSize
);

Remarks

Sets a signature window that restricts the ink of the SigPlus object to said window on the LCD itself (see setLCDCaptureMode).

Paramters

XPos-Location in LCD coordinates (upper left- 0,0)

YPos-Same

XSize-X size in LCD pixels

YSize-Y size in LCD pixels

Return Value

True if checksum received and verified, false if no or incorrect checksum received from tablet.

See Also


SigPlusNET.LCDStringHeight Method

public int LCDStringHeight(
Font DrawFont,
string Str
);

Remarks

Takes a string and a .NET font and hand back how tall the string is in pixels.

Parameters

DrawFont-.NET font

Str-String

See Also


SigPlusNET.LCDStringWidth Method

public int LCDStringWidth(
Font DrawFont,
string Str
);

Remarks

Takes a string and a .NET font and hand back how wide the string is in pixels.

Parameters

DrawFont->NET Font

Str-String

See Also


SigPlusNET.LCDWriteString Method

public bool LCDWriteString(
int Dest,
int Mode,
int XPos,
int YPos,
Font DrawFont,
string Str
);

Remarks

Used to write the image data to the LCD Display. The data is written at the location specified by the combination of Dest, XPos, and YPos. The Mode determines how the data is written.

Mode 0 - Clear: The Display is cleared at the specified location.
Mode 1 - Complement: The Display is complemented at the specified location.
Mode 2 - WriteOpaque: The contents of the background memory in the tablet are transferred to the LCD display, overwriting the contents of the LCD display.
Mode 3 - WriteTransparent: The contents of the background memory in the tablet are combined with and transferred to the visible LCD memory

Return Value

True if checksum received and verified. False if no checksum or checksum incorrect.

Parameters

Dest-0 = Foreground, 1 = Background memory in tablet

Mode-0, 1, 2, 3 as defined above

XPos-Location in LCD coords to draw at

YPos-Same

DrawFont-Not currently implemented, pass a 0

Str-ASCII hex string value.

See Also


SigPlusNET.NumberOfTabletPoints Method

public int NumberOfTabletPoints();

Remarks

Returns the total number of points in the current signature, can be used to detect if a signature is present or not.

Return Value

Decimal value of number of points in the signature.

See Also


SigPlusNET.OnPaint Method

protected override void OnPaint(
PaintEventArgs EvArgs
);

See Also


SigPlusNET.OnTimedEvent Method

protected void OnTimedEvent(
object Source,
ElapsedEventArgs E
);

See Also


SigPlusNET.SetAnnotate Method

public void SetAnnotate(
string Annotate
);

Remarks

Sets Annotation string.

Parameters

Annotate-ASCII line character.

See Also


SigPlusNET.SetAutoKeyData Method

public void SetAutoKeyData(
string KeyData
);

Remarks

Adds data to the auto key generation function. If called with file name (and path) when AutoKeyStart has not been initialized, this command will generate AutoKey data from a file rather than adding data via string. Used with AutoKeyStart and AutoKeyFinish methods, but called as a property.

Parameters

String containing the data, to be added to the key generation.

See Also


SigPlusNET.SetDisplayAnnotate Method

public void SetDisplayAnnotate(
bool DisplayAnnotate
);

Remarks

Sets the bean to display the Annotation string.

Parameters

DisplayAnnotate-Bean to display Annotation string.

See Also


SigPlusNET.SetDisplayAnnotateData Method

public void SetDisplayAnnotateData(
int XPos,
int YPos,
int Size
);

See Also


SigPlusNET.SetDisplayAnnotatePosX Method

public void SetDisplayAnnotatePosX(
int XPos
);

Remarks

Sets the X position in pixels of the start of the Annotation String in the signature box.

Parameters

XPos-X position for the start of the Annotation String to be set.

See Also


SigPlusNET.SetDisplayAnnotatePosY Method

public void SetDisplayAnnotatePosY(
int YPos
);

Remarks

Sets the Y position in pixels of the start of the Annotation String in the signature box.

Paramters

YPos-Y position for the start of the Annotation String to be set.

See Also


SigPlusNET.SetDisplayAnnotateSize Method

public void SetDisplayAnnotateSize(
int Size
);

Remarks

Sets the Y size of the Annotation start of the Time Stamp in the signature box.

Parameters

DisplayAnnotationSize- Y Size of Annotation text in pixels

See Also


SigPlusNET.SetDisplayMode Method

public void SetDisplayMode(
int Mode
);

Remarks

NOT CURRENTLY IMPLEMENTED

See Also


SigPlusNET.SetDisplayPenWidth Method

public void SetDisplayPenWidth(
int PenWidth
);

Remarks

Sets pen ink width for the displayed signature in pixels.

Parameters

PenWidth-Pen width for the displayed signature in pixels

See Also


SigPlusNET.SetDisplayRotate Method

public void SetDisplayRotate(
bool Mode
);

Remarks

Sets mode allowing signature rotation in the control after capture for Display only, does not save the .sig info rotated.

Parameters

DisplayRotation-Orientation for display of signature after capture.

See Also


SigPlusNET.SetDisplayRotateSave Method

public void SetDisplayRotateSave(
bool __unnamed000
);

Remarks

Sets mode allowing signature rotation and the save of signature in rotated format after capture. Does not save the .sig file rotated. Display rotation only. The rotation value is set by TabletRotation. Note: This is the preferred way of setting TabletMode = add 768 Can be used to rotate and then save in rotated format, signatures after capture, if the signature was accidentally taken in a rotated orientation during signature capture. Normally, to change the tablet orientation during capture, only the TabletRotation property is used.

Parameters

unnamed000-TRUE DisplayRotateSave mode = active, FALSE DisplayRotateSave mode = inactive

See Also


SigPlusNET.SetDisplayTimeStamp Method

public void SetDisplayTimeStamp(
bool DisplayTimeStamp
);

Remarks

Sets the bean to display the developer provided Time Stamp string.

Parameters

DisplayTimeStamp-Component to be set to display Time Stamp.

See Also


SigPlusNET.SetDisplayTimeStampData Method

public void SetDisplayTimeStampData(
int XPos,
int YPos,
int Size
);

See Also


SigPlusNET.SetDisplayTimeStampPosX Method

public void SetDisplayTimeStampPosX(
int XPos
);

Remarks

Sets the X position in pixels of the start of the Time Stamp in the signature box.

Parameters

XPos-X position to be set for start of display of Time Stamp

See Also


SigPlusNET.SetDisplayTimeStampPosY Method

public void SetDisplayTimeStampPosY(
int YPos
);

Remarks

Sets the Y position in pixels of the start of the Time Stamp in the signature box.

Parameters

YPos-Y position to be set for start of display of Time Stamp

See Also


SigPlusNET.SetDisplayTimeStampSize Method

public void SetDisplayTimeStampSize(
int Size
);

Remarks

Sets the Y size in pixels of the Time Stamp in the signature box.

Parameters

Size-Size of Time Stamp to set.

See Also


SigPlusNET.SetDisplayWindowRes Method

public void SetDisplayWindowRes(
bool Mode
);

Remarks

Sets mode which renders signatures in lower (screen) resolution for compatibility in printing directly from VB. MUST BE USED WHEN PRINTING DIRECTLY FROM A VISUAL BASIC FORM.

Parameters

Mode-TRUE DisplayWindowRes mode = active, FALSE DisplayWindowRes mode = inactive

See Also


SigPlusNET.SetEncryptionMode Method

public void SetEncryptionMode(
int EncryptionMode
);

Remarks

Sets EncryptionMode

Parameters

EncryptionMode-0= no encryption, 1= medium encryption, 2=higher security encryption mode

See Also


SigPlusNET.SetImageAnnotate Method

public void SetImageAnnotate(
bool ImageAnnotate
);

Remarks

Sets the bean to display the Annotation string as it applies to the WriteImageFile method.

Parameters

ImageAnnotate-Bean to be set to display Annotation string in the Image.

See Also


SigPlusNET.SetImageAnnotateData Method

public void SetImageAnnotateData(
int ImageAnnotatePosX,
int ImageAnnotatePosY,
int ImageAnnotateSize
);

Remarks

Sets display screen info for Annotate string. The default is the lower right corner, at ~8% of the screen high.

Parameters

ImageAnnotatePosX-X Location to display Annotate string at in signature display window using Logical Tablet Coordinates.

ImageAnnotatePosY-Y Location to display Annotate string at in signature display window using Logical Tablet Coordinates.

ImageAnnotateSize-Size to display Annotate string, in logical tablet coordinate height.

See Also


SigPlusNET.SetImageAnnotatePosX Method

public void SetImageAnnotatePosX(
int ImageAnnotatePosX
);

Remarks

Sets the X position in pixels of the start of the Annotation String in the signature box as it applies to the WriteImageFile method.

Parameters

ImageAnnotatePosX-X position for the start of the Annotation String to be set for Image

See Also


SigPlusNET.SetImageAnnotatePosY Method

public void SetImageAnnotatePosY(
int ImageAnnotatePosY
);

Remarks

Sets the Y position in pixels of the start of the Annotation String in the signature box as it applies to the WriteImageFile method.

Parameters

ImageAnnotatePosY-Y position for the start of the Annotation String to be set for Image

See Also


SigPlusNET.SetImageAnnotateSize Method

public void SetImageAnnotateSize(
int ImageAnnotateSize
);

Remarks

Sets the Y size of the Annotation start in the signature box as it applies to the WriteImageFile method.

Parameters

ImageAnnotateSize-Y size of Annotation text in pixels for Image.

See Also


SigPlusNET.SetImageFileFormat Method

public void SetImageFileFormat(
int FileFormat
);

Remarks

Sets the current format to use for Image files. The default is .BMP. The file extension is not assumed in the WriteImageFile function. Any extension can be specified, but it should match the specified file format. Note that writing an image file is completely different from a .sig file. An image file is just a standard image format of what is seen in the control and cannot be encrypted or decrypted by the SigPlus control. The .sig file format does not store an image, but rather uses a unique method of preserving the original signature data from the tablet. To create a metafile with a transparent background use a trio of instructions to set TabletOpaque = False, then WriteImageFile, the TabletOpaque = True. For all other image files, TabletOpaque must be true when the image file is written.

Parameters

FileFormat-File format for Image files.

0=Compressed BMP (default) must have .bmp ext.
1=Uncompressed BMP must have .bmp ext.
2=Mono. BMP must have .bmp ext.
3=JPG Q=20 must have .jpg ext.
4=JPG Q=100 must have .jpg ext.
5=Uncompressed TIF must have .tif ext.
6=Compressed TIF must have .tif ext.
7=WMF (windows metafile) must have .wmf ext.
8=EMF (enhanced metafile) must have .emf ext.
9=TIF (1-bit) must have .tif ext.
10=TIF (1-bit inverted) must have .tif ext.

See Also


SigPlusNET.SetImagePenWidth Method

public void SetImagePenWidth(
int ImagePenWidth
);

Remarks

Sets pen ink width as it applies to the WriteImageFile method.

Parameters

ImagePenWidth-Pen ink width for Image.

See Also


SigPlusNET.SetImageTimeStamp Method

public void SetImageTimeStamp(
bool ImageTimeStamp
);

Remarks

Sets the component to display the Time Stamp as it applies to the WriteImageFile method.

Parameters

ImageTimeStamp-Component to be set to display developer provided Time Stamp.

See Also


SigPlusNET.SetImageTimeStampData Method

public void SetImageTimeStampData(
int ImageTimeStampPosX,
int ImageTimeStampPosY,
int ImageTimeStampSize
);

Remarks

Sets display screen info for Time and Date stamp. The default is the lower left corner, at ~8% of the screen height.

Parameters

ImageTimeStampPosX-X, Location to display TimeStamp string at in signature display window using Logical Tablet Coordinates.

ImageTimeStampPosY-Y Location to display TimeStamp string at in signature display window using Logical Tablet Coordinates.

ImageTimeStampSize-Size to display TimeStamp string, in logical tablet coordinates high.

See Also


SigPlusNET.SetImageTimeStampPosX Method

public void SetImageTimeStampPosX(
int ImageTimeStampPosX
);

Remarks

Sets the X position in pixels of the start of the Time Stamp as it applies to the WriteImageFile method.

Parameters

ImageTimeStampPosX-X position to be set for start of Time Stamp for Image.

See Also


SigPlusNET.SetImageTimeStampPosY Method

public void SetImageTimeStampPosY(
int ImageTimeStampPosY
);

Remarks

Sets the Y position in pixels of the start of the Time Stamp as it applies to the WriteImageFile method.

Parameters

ImageTimeStampY-Y position to be set for start of Time Stamp for Image.

See Also


SigPlusNET.SetImageTimeStampSize Method

public void SetImageTimeStampSize(
int ImageTimeStampSize
);

Remarks

Sets the Y size in pixels of the Time Stamp in the signature box as it applies to the WriteImageFile method.

Parameters

ImageTimeStampSize-Size of Time Stamp to set for Image.

See Also


SigPlusNET.SetImageXSize Method

public void SetImageXSize(
int ImageXSize
);

Remarks

Sets the number of X pixels in the image provide by the WriteImageFile method.

Parameters

ImageXSize-Size in X pixels of the Image width.

See Also


SigPlusNET.SetImageYSize Method

public void SetImageYSize(
int ImageYSize
);

Remarks

Sets the number of Y pixels in the Image height as provided by the WriteImageFile method.

Parameters

ImageYSize-Size in y pixels of the Image height.

See Also


SigPlusNET.SetJustifyMode Method

public void SetJustifyMode(
int JustifyMode
);

Remarks

Sets the current justification mode- how the signature is sized and positioned in the signature box as well as when using the WriteImageFile method.

Parameters

JustifyMode-Justification mode, 0-normal no justification, 1-justify and zoom signature (upper left corner) 2-justify and zoom signature (upper right corner) 3-justify and zoom signature (lower left corner) 4-justify and zoom signature (lower right corner) 5-justify and zoom signature (center of control).

See Also


SigPlusNET.SetJustifyX Method

public void SetJustifyX(
int JustifyX
);

Remarks

Sets the buffer size in Logical Tablet Coordinates of "dead space" of left and right edge of SigPlus object if JustifyMode is 1-5. This method functions for both the signature box as well as when using the WriteImageFile method.

Parameters

JustifyX-Justification X buffer size in pixels to be set.

See Also


SigPlusNET.SetJustifyY Method

public void SetJustifyY(
int JustifyY
);

Remarks

Sets the buffer size in Logical Tablet Coordinates of "dead space" of top and bottom edge of SigPlus object if JustifyMode is 1-5. This method functions for both the signature box as well as when using the WriteImageFile method.

Parameters

JustifyY-Justification Y buffer size in pixels to be set.

See Also


SigPlusNET.SetKeyString Method

public void SetKeyString(
string KeyString
);

Remarks

Sets the Key String into the SigPlus component.

Parameters

KeyString-Hash of the data used to encrypt/decrypt the signature, key internally generated by SigPlus.

See Also


SigPlusNET.SetLCDCaptureMode Method

public void SetLCDCaptureMode(
int CaptureMode
);

Remarks

Sets the current LCD Capture Mode for the tablet.

Parameters

CaptureMode-Mode the LCD is set to capture signatures in,

Mode 0=no LCD commands are sent to the tablet
Mode 1=sets capture mode to be active with Autoerase in the tablet
Mode 2=sets the tablet to persistent ink capture without autoerase
Mode 3=signature ink is displayed inverted on a suitable dark background set using the Graphic functions.

See Also


SigPlusNET.SetSaveSigInfo Method

public void SetSaveSigInfo(
bool SaveSigInfo
);

Remarks

Enables/Disables the saving of TimeStamp and Annotate data in the signature.

Parameters

SaveSigInfo-If True then SigInfo will be saved (default), if False then the info will not be saved.

See Also


SigPlusNET.SetSigCompressionMode Method

public void SetSigCompressionMode(
int CompressionMode
);

Remarks

Sets the current compression mode for signatures.

Parameters

CompressionMode-Mode for compression of signature, where 0= no compression, 1= lossless compression with compacted data format, 2-8= compression ratio of signature stored in in .sig file where 2=1KB typ, 4=500 byte typ, and 8=250 byte typ. Topaz Systems does not recommend compressing beyond setting 1 unless size is more improtatn than signature quality.

See Also


SigPlusNET.SetSigString Method

public void SetSigString(
string SigString
);

Remarks

Puts signature into the component.

Parameters

SigString-Signature in ASCII format.

See Also


SigPlusNET.SetSigWindow Method

public void SetSigWindow(
short Coords,
short NewXPos,
short NewYPos,
short NewXSize,
short NewYSize
);

Remarks

This function sets a window in the logical tablet space that restricts the operation of some functions to the specified window. The functions behave as follows: JustifyMode will only operate on points inside of this window. ExportSigFile and WriteImageFile will only operate on points inside the window. SigString only operates on points inside of the window. ClearTablet will only clear in the window. This behavior is enabled by setting the start and stop values to non-zero. The window defaults to (0,0,0,0). The window can be enabled at one spot, re-enabled at another, etc., without disabling in between, and then disabled when the various parts of the tablet data have been separated and stored. To determine the logical values in the control for the installed tablet, see the TabletLogicalXSize and TabletLogicalYSize properties.

Parameters

Coords-Coordinate system used for this hot spot, 0 = Logical tablet coordinates, 1 = LCD Coordinates.

NewXPos-Location in logical tablet coordinates (upper left - 0,0).

NewYPos-Same

NewXSize-XSize in logical tablet pixels

NewYSize-YSize in logical tablet pixels

See Also


SigPlusNET.SetTabletBaudRate Method

public void SetTabletBaudRate(
int BaudRate
);

Remarks

Sets TabletBaudRate, an internal property associated with tablet model.

Parameters

BaudRate-internal tablet property.

See Also


SigPlusNET.SetTabletComPort Method

public void SetTabletComPort(
int Port
);

Remarks

Sets the COM port to use using a string. The SigPlus.NET component does not lock up a port as is the case with mouse-type drivers. Only set COM port when tablet state is OFF.

Parameters

Port-

See Also


SigPlusNET.SetTabletComTest Method

public void SetTabletComTest(
int ComTest
);

Remarks

Sets harware check mode. When this mode is active and Topaz tablet plugged into selected COM port (or USB) TabletState can be set to 1(ON). If tablet cannot be set to 1.

Parameters

ComTest-Hardware check mode.

See Also


SigPlusNET.SetTabletFilterPoints Method

public void SetTabletFilterPoints(
int Points
);

Remarks

Sets the TabletFilterPoints, an internal property associated with tablet model.

Parameters

Points-Internal tablet property.

See Also


SigPlusNET.SetTabletLogicalXSize Method

public void SetTabletLogicalXSize(
int XSize
);

Remarks

Sets the Range of horizontal values to be used in representing signatures. This has no relation to the displayed, image file, or tablet sizes. This is the X-range used for the Topaz vector format, and the internally used format.

Parameters

XSize-Integer value of Tablet logical size. Default is 2150.

See Also


SigPlusNET.SetTabletLogicalYSize Method

public void SetTabletLogicalYSize(
int YSize
);

Remarks

Sets the range of vertical values to be used in representing signatures. This has no relation to the displayed, image file, or tablet sizes. This is the Y-range used for the Topaz vector format, and the internally used format.

Parameters

YSize-Integer value of Tablet logical size. Default is 1400.

See Also


SigPlusNET.SetTabletResolution Method

public void SetTabletResolution(
int Resolution
);

Remarks

Sets TableResolution, an internal property associated with tablet model and set by the TabletModel property, based on hardware tablet resolution is 410 dpi, (excluding ClipGem which is 275 dpi) but can be changed at teh risk of affecting signature capture.

Parameters

Resolution-Internal tablet property.

See Also


SigPlusNET.SetTabletRotation Method

public void SetTabletRotation(
int Rotation
);

Remarks

Sets the orientation on a 360 degree axis for display of tablet data. The data in the sig representation is stored in the native tablet orientation.

Parameters

Rotation-Display orientation, allowed values are 0, 90, 180, 270.

See Also


SigPlusNET.SetTabletState Method

public void SetTabletState(
int State
);

Remarks

Enables tablet to acess the COM or USB port to capture signatures or not.

Parameters

State-setting to 1 enables the tablet to capture signatures as above, setting to 0 disables signature capture.

See Also


SigPlusNET.SetTabletTimingAdvance Method

public void SetTabletTimingAdvance(
int Advance
);

Remarks

Sets the TabletTimingAdvance, an internal property associated with tablet model.

Parameters

Advance-Internal tablet property.

See Also


SigPlusNET.SetTabletType Method

public void SetTabletType(
int TabletType
);

Remarks

Determines if the tablet will accept data from a com port, WinTab driver, USB driver or other method of data input. If WinTab support is not available, it will not do anything when in the active state. Conversely, if WinTab is present and the mode is not correct, the tablet will also do nothing when active, because the WinTab driver takes exclusive possession of the Com Port. This is the preferred way of setting TabletMode for tablet input.

Parameters

TabletType-Default is 0

0=Normal mode. When tablet is activated it will accept input from the selected com port.
1=WinTab mode,when the tablet is activated, it will accept data from the Topaz WinTab driver only.
2=USB mode, when the tablet is activated, it will accept data from the Topaz USB driver
3=TracGemPOST signature format, Transparent Mode (CTRL T)
4=Older-model SigLite touch tablet format, an obsolete mode
6=HSB tablet (USB mode for tablets using HID driver)

See Also


SigPlusNET.SetTabletXStart Method

public void SetTabletXStart(
int XStart
);

Remarks

Sets the X position in Logical Tablet Coordinates of the upper left hand corner of the bean signature box.

Parameters

XStart-X coordinate of the upper left corner of the signature box.

See Also


SigPlusNET.SetTabletXStop Method

public void SetTabletXStop(
int XStop
);

Remarks

Sets the X position in Logical Tablet Coordinates of the lower right corner of the bean signature box.

Parameters

XStop-X coordinate for the lower right corner of the signature box.

See Also


SigPlusNET.SetTabletYStart Method

public void SetTabletYStart(
int YStart
);

Remarks

Sets the Y position in Logical Tablet Coordinates of the upper left corner of the signature box.

Parameters

YStart-Y coordinate for the upper left corner of the signature box.

See Also


SigPlusNET.SetTabletYStop Method

public void SetTabletYStop(
int YStop
);

Remarks

Sets the Y position in Logical Tablet Coordinates of the lower right corner of the signature box.

Parameters

YStop-Y coordinate for the lower right corner of the signature box.

See Also


SigPlusNET.SetTimeStamp Method

public void SetTimeStamp(
string TimeStamp
);

Remarks

Sets the TimeStamp string for the signature.

Parameters

TimeStamp-ASCII new line character.

See Also


SigPlusNET.Sleep Method

public void Sleep(
uint TimeInMs
);

See Also


SigPlusNET.WriteImageFile Method

public bool WriteImageFile(
string FileName
);

Remarks

The control will write out a signature file in the current Image file format. The default is .BMP. See the property SetImageFileFormat to set an image type other than BMP. Other supported image formats include JPG, TIF, WMF, EMF. The full Filename must be provided, including the standard file extension.

Return Value

TRUE if successful, FALSE if not successful

Parameters

Filename-FileName is a string, containing the path and filename to write to.

See Also


TopazHierarchy

SigPlus.Net Documentation

Topaz Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
System.Windows.Forms.Control ---- System.ComponentModel.ISynchronizeInvoke, System.Windows.Forms.IWin32Window
Topaz.SigPlusNET

See Also

Topaz Namespace