Description

SigSign is an ActiveX control composed of the SigPlus ActiveX control on a dialog. SigSign is designed to be used in environments where there is no wysiwyg Design Time form available to the developer, such as Domino.

Here is an example of SigSign:

Copyright 1995 - 2005, Topaz Systems, Inc. All Rights Reserved

Topaz products are covered under US patents 5,120,908 5,122,623 6,307,955 - "Electronic Signature Management System", and patents pending

Topaz Systems, Inc., 650 Cochran Street, Unit 6, Simi Valley, CA, USA, 93065 Phone: 805 520-8282 Fax: 805 520-0867 www.topazsystems.com


GetSignature ()

Generates the window to capture signature with Accept, Clear, or Cancel

Return: Boolean

True if signature is captured and user clicks 'Accept'

False if user clicks cancel.

Example:

Dim strSig As String

If SigSign1.GetSignature = True Then 'this brings up the signing dialog

mySig = SigSign1.SigString

End If


SetCompressionMode (int)

Sets the current compression mode for signatures

Parameters:

SigCompressionMode- Mode for compression of signature

0= no compression

1= lossless compression with compacted data format

2-8= compression ratio of signature stored in in .sig file where 2=1KB typ, 4=500 byte typ, and 8=250 byte typ.

Topaz Systems does not recommend compressing beyond setting 1 unless size is more important than signature quality

Example:

SigSign1.SetCompressionMode(1)


SetTabletArea (int xstart, ystart, xstop, ystop)

Sets the signature window that will record information from the pen

Parameters:

xstart- Left most pixel of signature window

ystart- Top most pixel of the signature window

xstop- Right most pixel of the signature window

ystop- Bottom most pixel of the signature window

Example:

SetTabletArea(400, 2400, 350, 950) 'this sets SigSign up for a SignatureGem1X5 tablet


GetSigString ()

Returns signature as an ASCII hex string.

Returns:

ASCII hex string of signature

Example:

If SigSign1.GetSignature = True Then 'this brings up the signing dialog

mySig = SigSign1.SigString

End If


GetTitle1 ()

Returns the current setting for Title 1.

Returns:

Current Title1

Example:

SigSign1.Title1 = "Title 1"


GetTitle2 ()

Returns the current setting for Title 2.

Returns:

Current Title2

Example:

SigSign1.Title2 = "Title 2"


GetWindowTitle ()

Returns the title of the Signing Window.

Returns:

Title of signing window

Example:

SigSign1.WindowTitle = "Window Title"


SetSigString (string)

Assigns the sig string from SigSign to SigPlus

Parameters:

SigString

Example

If SigSign1.GetSignature = True Then 'this brings up the signing dialog

mySig = SigSign1.SigString

End If


SetTitle1 (string)

Sets the Title 1

Paramters:

Title 1

Example:

SigSign1.Title1 = "Title 1"


SetTitle2 (string)

Sets Title 2

Parameters:

Title 2

Example:

SigSign1.Title2 = "Title 2"


SetWindowTitle (string)

Sets the title of signing window

Paramters:

WindowTitle- The title of the singing window

Example:

SigSign1.WindowTitle = "Window Title"


Important Notices

License Agreement and Limited Warranty

IMPORTANT: Please read this document before continuing the software load procedure. By loading the software enclosed with this agreement, you are indicating acceptance of the terms of this legal agreement between you (herein call Licensee) and Topaz Systems, Inc. (herein called Topaz). If you do not agree to the terms of this agreement, do not load the enclosed software and promptly return the product.

1. Limited use License: Topaz and it’s suppliers (if any) grant you the right to use the software for use with Topaz Gem-Series tablets only. The software is owned for distribution exclusively by Topaz and is protected by the United States Patent and Trademark laws and international treaties.

2. Governing Law, Jurisdiction, and Forum: This agreement is governed by the laws of the State of California, County of Ventura.

3. YOU MAY:

(a) Freely use, copy, and distribute the enclosed software only for use with Topaz Gem-Series tablets.

4. YOU MAY NOT:

(a) Use, distribute or modify the Topaz software for use with tablets not supplied by Topaz Systems, Inc.

(b) Reverse engineer, decompile, or dis-assemble, the software.

5. LIMITED WARRANTY:

Topaz Systems warrants to the original buyer only, that the media upon which the Software is recorded is free from defects in workmanship and material under normal use and service for a period of 30 days.

6. EXCLUSIVE REMEDY:

Topaz’s entire liability and your exclusive remedy shall be, at Topaz’s option, either (a) the repair or replacement of the software or (b) the refund of the price that was paid for the software package. The defective software, along with proof of payment, must be returned to Topaz within the terms of the warranty as set forth in this agreement.

7. LIMITATIONS ON DAMAGES:

In no event shall Topaz be liable for damages whatsoever, (including without limitation, damages for loss of profits, business interruption, loss of information, or other pecuniary loss) arising out of the use of or inability to use the software even it Topaz or it’s suppliers, if any, have been advised have been advise of the possibility of such damages. In no event will Topaz’s liability for any reason exceed the actual price paid for the license to use the specific program.

8. NO OTHER WARRANTIES:

With respect to the software, media, and written material, Topaz and it’s suppliers, if any, disclaim all warranties, other than the above Topaz warranty, including but not limited to warranties merchantability or fitness for a particular use. Topaz does not warranty the software will meet or requirements or that the operations of the software will be uninterrupted or error free.

9. GOVERNING LAW AND GENERAL PROVISIONS:

If any part of this agreement is found void and unenforceable, it will not effect the validity of the balance of the agreement, which shall remain valid and enforceable according to it’s terms. You agree that the software will not be shipped, transferred, or exported into any country or used in any manner prohibited by the United States Export Administration Act or any other export laws, restrictions or regulations. This agreement shall automatically terminate upon failure of you to comply with it’s terms. This agreement may only be modified in writing signed by an officer of Topaz Systems, Inc. This agreement will not be governed by the United Nations convention on contracts for the International sale of goods, the application of which is expressly excluded.

Statement regarding patents, and warning against modification of Topaz products:

Topaz products are covered under US patents 5,120,908 and 5,122,623. Patent work is ongoing and pending. Use of Topaz's products in accordance with our instructions, to the best of our knowledge, does not infringe any patents. However, be aware that there are many patents out there, and modification of our products, or use of our products for other than their intended purpose, could run afoul of these patents. It is the responsibility of Topaz customers to honor relevant patents. U. S. Patent Nos. 5,544,255; 5,647,017; 5,818,955 and others are patents that users of Topaz products should consider if modifications are to be made to our products or if our products are to be used for other than their intended purpose. These patents may be obtained at http://www.uspto.gov.Only as examples, without first considering these patents, you should refrain from storing within the signature information (sig file or sig data):

1. A reason for signing or a statement of importance of the signature together with a set of measurements relating to the handwritten signature and either an indication of the signatory or means for comparing said measurements with a set of statistics of a genuine signature to obtain a similarity score.

2. A visual representation of a signature together with a document checksum, hash, or receipt, and the claimed identity of the signatory.

3. A set of measurements relating to biometric information together with a document checksum, hash, or receipt, and the claimed identity of the user.

The foregoing statement is not intended to be an interpretation of the patents or their application to any particular product or implementation.

It may be possible that Federal (FDA) and state digital signature regulations become violated if techniques in 1, 2, and 3 above are employed, so rest assured, Topaz software does not do any of them. Note the information below:

1. The FDA regulations state that "Signed electronic records shall contain information associated with the signing that clearly indicates all of the following ...printed name ... date and time ... The meaning ...". (see FDA guidelines section 11.50) The FDA regulations treat electronic records and electronic signatures as different entities (Section 11.70). Therefore, you should refrain from modifying the Topaz system on your own to store any of the name, date and meaning data in the signature file.

2. State regulations such as CA code of Regulations, Title 2, Division 7, Chapter 10 for example, require that the signature be bound to only the single message that is signed and not to any other message. Therfore you should refrain from modifying the Topaz system on your own to place a checksum in with the signature data and then adding other information in with the signature, and then encrypting them to a secret key. If your were to modify the Topaz system to do this, you would be binding the signature to multiple-messages which is prohibited by the state regulations.

3. State regulations require that the signature data be capable of verification by a forensic document examiner. (CA regulations paragraph 220003(b)(3)(B) for example). Some of the techniques in 1-3 above appear at odds with "lengthy process of handwriting analysis" required by state regulation (see state of CA FAQ section). With the Topaz system, you are assured of the most accurate forensic handwriting analysis results, since the Topaz .sig file is saving all of the original signature data.

In addition, there are potential security and refutability issues if too many things are crammed in with the signature. Leave the document data, reason for signing, receipt, and identity information in the document as GemTools is designed to work, and as complies with FDA and state regulations. That way, the signature is bound to all of the data, not just to part of the data. It is very easy to create all kinds of standard image files of the signature using GemTools software. Topaz signature & document security results from our patent pending methods of encrypting the .sig data directly to a document hash (not by putting the hash or receipt into the .sig file), and non-repudiation results from the proper use of (again patent pending) Topaz signature and document receipts. Please contact the factory if you have any additional questions or would like more information about your rights concerning patents as a customer or developer using Topaz products.

Important Notice:

This software or any or all additional documentation, guidelines, or examples do not constitute a warranty about the performance, security, or legal acceptability of GemTools software or the SigPlus control in any specific use or implementation. To the extent that GemTools or SigPlus are used to achieve regulatory or other specific objectives within an industry, you must consult competent experts or regulatory officials together with your own plan to achieve your desired business objectives using the Topaz tools.