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Overview 

The Topaz Access Demo How-To Guide serves as an example for adding Topaz signature 
capture to your own database. Ultimately, you should use the techniques suggested in this 
document and apply them to your database.  
 
If you have any questions about implementation, contact Topaz Dev Support at: 
www.topazsystems.com/contact_devsupport.html. 

 

Download and Install Software 

1. To begin, open up Access. Click “File”  “Account”  “About Access”. At the top of the 
window, check if you have MS Office 32-bit or 64-bit. 
 

 
 
a. For 32-bit users:  

Download and install SigPlus® Pro ActiveX from the following link: 
www.topazsystems.com/Software/sigplus.exe 

 
b. For 64-bit users: 

Download and install SigPlus® Pro ActiveX from the following link: 
www.topazsystems.com/Software/sigplus64.exe 

 
 

2. Then, download and install the SigPlus ActiveX Demo for Access from the following 
page: www.topazsystems.com/access.html 

 

 

Creating Code for Sign, Clear, and Done Buttons 

 
1. Open the .zip file that is downloaded, and then open the “SignMeUp” Access file.  

 

2. If a “Security Warning” appears at the top, click “Enable Content”. If the file opens in 
Read-Only mode, follow the instructions to save a copy of the database. 
 

 

http://www.topazsystems.com/contact_devsupport.html
http://www.topazsystems.com/Software/sigplus.exe
http://www.topazsystems.com/Software/sigplus64.exe
http://www.topazsystems.com/access.html
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3. Click the “Create” tab, and select “Table Design”. 
 

 

4. This will bring up the “Table Design View” window. 
 

 
 

5. In the “Field Name” column, enter “Signature”. In the “Data Type” column, choose “Long 
Text” (Note: in versions of Access 2010 and before, choose “Memo” instead of “Long 
Text”). In the “Description” column, enter any description desired. This field will hold the 
signature. 
 

 
 

6. Once the fields are added, save the table simply by closing the table. A window will 
appear asking if the user wants to save changes. Click “Yes”, and a “Save As” window 
will appear. Name the table, and click “OK”. 
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7. Once the user clicks “OK”, a window will appear that denotes no primary key was 
defined. Unless denoted by a developer or system administrator, click “Yes” and allow 
Access to create a primary key for the table. 
 

8. Once the table has been created and saved, the next step is to create a new form by 
clicking the “Create” tab, and then clicking “Form Wizard”. 
 

 
 

9. This will open the “Form Wizard” window. Be sure the table you saved earlier is 
selected under the “Tables/Queries” section. Place the signature field in the “Selected 
Fields” box by highlighting the signature field in the “Available Fields” box and using the 
arrows to move it over to the “Selected Fields” box. Then, click “Finish”.  
 

 
 
Note: the ID Field does not need to be added to the “Selected Fields” box. 
 

10. After clicking “Finish”, the form will be created. To make necessary changes to the form, 
the user must be in “Design Mode”. To go into “Design Mode”, click the “Home” tab, and 
select “Design View” under “View”. 
 

 



  
    

6 www.topazsystems.com Back to Top 

Access Demo How-To Guide 

11. Once in “Design View”, the form that has been created will be easy to edit and to add 
the requisite buttons and controls. 
 
Note: In the following steps, the “Design Toolbox” will be used. This can be found under 
the “Design” tab. 
 

12. Once in “Design View”, right-click on the white signature box to select it, and choose 
“Properties”. 
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13. Under the “All” tab, make sure the “Visible” property says “No”. 
 

 
 

14. Next, resize the signature box. The less room it takes up, the better. 
 

 
 

15. Next, delete the “Signature” header by highlighting it and using the backspace key.  
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16. Once deleted, the user must add the SigPlus ActiveX controls. Do so by selecting the 
“Design” tab, clicking the “More” arrow in the bottom right corner of the toolbox and 
selecting “ActiveX Controls”. 
 

 
 

17. This will bring up a window to choose which controls to add. Choose “SigPlus Control”, 
and click “OK”. 
 

 
 

18. This will add a white box to the form. The user can resize this and place it anywhere in 
the form by simply clicking and dragging it. 
 

 
 
Note: This is where the visible signatures will be displayed, so take that into account 
when resizing this control. 
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19. Once the control is added and resized, the form may look something like the image 
above, but the user can place the control wherever they desire. 
 

20. Right-click on the white box and select “Properties”. Then, rename the control under the 
“All” tab. The SigPlus Control, denoted by the white box, needs to be renamed 
“SigPlus1”. 
 

 

21. Once the control has been renamed, the user must now add a control button. The 
control button can be found in the “Toolbox”, located under the “Design” tab. Click on 
“Button” (see the below image), and then click and drag it to desired size on the form.  
 

 
 

22. When the “Command Button Wizard” window opens, click “Cancel”. 
 

 
 
This will allow the placement of a “Command Button” without any programming code 
included or attached. 
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23. Once the “Command Button” is placed in the form, right-click on it and select 
“Properties”. Change the “Name” section to read “Capture” and the “Caption” section to 
read “Sign” under the “All” tab, and then click the “Event” tab. 
 

 
 

24. For the “On Click” section, select “Event Procedure” from the drop-down menu. Then, 
click the ellipses to the right of the drop-down menu. 
 

 
 

25. Clicking on the ellipses will open up a Visual Basic window that contains the coding for 
the Event Procedure. 
 

 
 

26. Now, create a “Done” button by repeating the instructions described in steps 23-27 
above.  
 
Note: Both rename and caption the new button “Done”, as described in step 25 above.  
 
Once steps 23-27 are repeated for the “Done” button, the coding will look like this: 
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Your form will look similar to this: 
 

 
 

27. To get the proper coding for the “Capture_Click” event, open the “Roster” form that was 
loaded when the “SignMeUp” Access file was opened.  
 

 
 

28. Make sure you are in “Design View” before proceeding, by clicking on the “Home” tab 
and selecting “Design View” under the “View” button. 
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29. Right-click on the button that says “Sign”, and select “Properties”.  
 

 
 
Under the “Event” tab, make sure the “On Click” section says “Event Procedure”, and 
click the ellipses to the right of the drop-down menu. 
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30. This will open the Visual Basic window. Highlight and copy the code from the 
“Capture_Click” Event section. 
 

 
 

31. Once the code is copied, paste it into the code for the sample table that was created. 
This will ensure that the proper coding is attached to the “Capture_Click” event. 
 
The code for the “SampleTable” form should still be opened under the “Microsoft Visual 
Basic for Applications – SignMeUp” window. The code window is likely to be hidden 
behind the “Roster” form’s code window. 
 

 
 

32. Now that the “Sign” button is set-up, we will set-up the “Done” button. First, make sure 
you are still in “Design View” (Under the “Home” button, select “View” and “Design 
View”).  
 
 
 
 



  
    

14 www.topazsystems.com Back to Top 

Access Demo How-To Guide 

33. In the “Roster” form, right-click on the “Done” button and select “Properties”. 
 

 
 

34. Under the “Event” tab, make sure the “On Click” section reads “Event Procedure”, and 
click the ellipses to the right of the drop-down menu. Highlight and copy the code from 
the “Done_Click” Event section. 
 

 
 

35. Once the code is copied, paste it into the code for the sample table that was created. 
This will ensure that the proper coding is attached to the “Done_Click” event. 
 
The sample table’s code should still be opened under the “Microsoft Visual Basic for 
Applications – SignMeUp” window. The code window is likely to be hidden behind the 
“Roster” form’s code window. 
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The “SampleTable” form’s code will now look something like this: 
 

 
 

36. Next, we will copy the “SigPlusD” code from the “Form_Roster” code window to the 
“Form_SampleTable” code window. In the “Form_Roster” code window, scroll to the 
top; highlight and copy the line seen below: 
 

 
 

37. Go back to the “Form_SampleTable” code window; scroll to the top, and paste the line 
you copied under the “Option Compare Database” line as seen below: 
 

 
 

38. Now that we have copied the “SigPlusD” code into the “Form_SampleTable” code 
window, we will create and copy the “FormLoad” event. In Access, view the 
“SampleTable” form in “Design View”, as you have done before. 
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Left click in the gray-dotted area of the “SampleTable” form; then, left-click the white 
square in the upper-left corner of the form. A black dot will appear in the middle of the 
square. Right-click on the square, and select “Properties”. Under the “Event” tab, in the 
“On Load” section, select “Event Procedure” from the drop-down menu, and click the 
ellipses to the right of the drop-down menu. 
 

 
 
 

39. This will create a “Form_Load” section in the “Form_SampleTable” code (see below). 
 

 
 

40. Now, go back to the “Roster” form. Be sure you are in “Design View”, as you have done 
before. Repeat the same instructions from step 40 above for this form. 
 

41. Highlight and copy the “FormLoad” code, seen below. 
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42. Return to the “Form_SampleTable” code window, and paste the code you copied in the 
Form_Load section you created in step 41. Your “SampleTable” code will now look 
similar to this: 
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43. Now we will add the code to draw the signature in real time as you sign. First, add a 
timer to your form. Left click in the gray-dotted area of the “SampleTable” form; then, 
left-click the white square in the upper-left corner of the form.  
 
A black dot will appear in the middle of the square. Right-click on the square, and select 
“Properties”. Under the “Event” tab, in the “On Timer” section, select “Event Procedure” 
from the drop-down menu, and click the ellipses to the right of the drop-down menu. 
 
This will add the “Form_Timer” code to the “SampleTable” form’s code. 
 

 
 

44. Now, return to the “Roster” form (double-click on “Roster” in the left column). Complete 
step 45 above for the “Roster” form now.  
 
NOTE: In the “Properties”, under the “Event” tab, the “On Timer” section will already say 
“Event Procedure”. Simply click on the ellipses to the right of the drop-down menu.  
 

45. In the “Roster” code, find the “Form_Timer” section, and highlight and copy the line 
seen below: 
 

 
 

46. Return to the “SampleTable” code window, and paste the line you just copied into the 
code.  
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47. Your code window will look something like this: 
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48. Next, create a “Clear” button. Open the “SampleTable” in “Design View” mode. In the 
“Design” tab, click “Button”, as seen below. 
 

 
 

49. Click and drag the button to the desired size and position. When the “Command Button 
Wizard” window opens, click “Cancel”. 
 

 
 

50. If the “Properties” column isn’t open on the right, right-click on the button you just 
created and click “Properties”. Under the “All” tab, change the Name and Caption 
sections to both read “Clear”. 
 

 
 
Click on the “Event” tab; under the “On Click” section, select “Event Procedure” from the 
drop-down menu, and click the ellipses to the right of the drop-down menu. 
 

51. This will create the “Clear_Click” event in the code, as seen below: 
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52. In the line after “Private Sub Clear_Click()”, type the following code: 
 
SigPlus1.ClearTablet 
SigPlusD.ClearTablet 
 
 
The code will look like this: 
 

 
 

53. Once the above steps have been completed, the user can test the form by viewing it in 
“Form Mode” instead of “Design Mode”. Click the “Sign” button and sign on your 
signature pad. The signature will appear in the space provided if the code has been 
done correctly. 
 

 
 

54. If you are satisfied with the signature, click “Done” and the signature will zoom to fit. To 
sign again, click “Clear” and “Sign” again. 
 

 
 

55. Once all the functions are tested, we can move on with the creation of the forms and 
database. 
 
 



  
    

22 www.topazsystems.com Back to Top 

Access Demo How-To Guide 

Creating Code for Navigation Buttons 

 
1. With all the components working properly, the user can now add navigation buttons. To 

do this, start by adding another control button. Open the “SampleTable” in “Design 
View” mode. In the “Design” tab, click “Button”, as seen below. 
 

 
 

2. Click and drag the button to the desired size and position. When the “Command Button 
Wizard” window opens, choose “Record Navigation” in the “Categories:” section and 
choose “Go to Previous Record” in the “Actions:” section. 

 
 

3. Click “Next”. This will bring up the second page of the wizard. Here, the user can 
choose the appearance of the “Command Button”. The “Sample:” section on the left 
will give a preview of how the button will look. 
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4. Click “Next”. The last page allows for the user to name the button. Name the button 

something easy to remember and indicative of the button’s function. 

 

5. Click “Finish” and the button will be added to the form. 

 

6. Once the button has been added to the form, the next step is to add the SigPlus coding 

to the button.  This is accomplished in much the same way as was the addition of code 

to the “Sign” button previously.  Right-click the button and select “Properties”. 

 

7. Under the “All” tab, change the “Name” and “Caption” sections to both read “Back”. 

Click on the “Event” tab; under the “On Click” section, select “Event Procedure” from the 

drop-down menu, and click the ellipses to the right of the drop-down menu. 
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8. Open up the “Roster” form in “Design View”. Right-click on the “Back” button and select 

“Properties”. Under the “Event” tab, click the ellipses to the right of the drop-down menu 

in the “On Click” section. 

 

 
 

9. Copy and highlight the code seen below in the “Back_Click” section. 
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10. Return to the “Form_SampleTable” code window and paste the code you copied into 

the “Back_Click” section you created in step 6.  

 

11. Repeat the above steps 1-10 to create several more buttons: “Next”, “Add”, “Delete”, 

“Save”, and “Close”.  

 

NOTE: When repeating steps where information is input for these buttons, use the 

following information in the Command Button Wizard and in the “Properties” sections; 

when copying code for each button from the “Roster” form to the “SampleTable” form, 

note the name of the “Code Section” below to copy in the code window. 

 

Name/Caption Categories Actions Code Section 

Next Record Navigation Go To Next Record Next_Click() 

Add Record Operations Add New Record Add_Click() 

Delete Record Operations Delete Record Delete_Click() 

Save Record Operations Save Record Save_Click() 

Close Form Operations Close Form Close_Click() 

 

 

12.  Once all four buttons have been added, the form may look something like this, though 

many of the components can be sized and placed differently. 

 

 
 

13. Once the code has been added, the last step is to turn off the Access-provided 

navigation buttons (these are not the buttons that the user has added), as these 

buttons interfere with the proper functionality of SigPlus. 
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14. Left click in the gray-dotted area of the “SampleTable” form; then, left-click the white 

square in the upper-left corner of the form. A black dot will appear in the middle of the 

square. Right-click on the square, and select “Properties”.  

 

 
 

15. Under the “All” tab, in the “Navigation Buttons” section, select “No” from the drop-down 

menu. 
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Adding Signatures to an Access Report 

1. Under the “Create” tab in the main Access menu, click on the “Report Wizard” button.  
 

2. First, select “Table: Roster” from the “Tables/Queries” menu. Then, select which fields 
you would like displayed in your report. You can select any number of options from the 
list. To add a single field, select that field and click the single arrow. To add all fields, 
use the double arrow button. The same principle applies for deselecting items, but use 
the opposite arrow.  For the purposes of this demo, we will select them all. When you’re 
done, click “Next”. 

 
 

3. You can now specify the order of fields and how they are grouped. This is an optional 
step. When done, click “Next”. 
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4. Next, you can sort the records and order them (ascending or descending order). In our 
example, we use the default settings. When done, click “Next”. 
 

 

 

5. Setup the layout of your report to meet your personal aesthetic tastes. In our example, 
we use the justified layout, orientated like a portrait. We recommend you check the 
option to “adjust the field width so all fields fit on a page”. When you’re done, click 
“Next”. 
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6. Lastly, name your new report. We used the title “Topaz Test Report” for our purposes. 
Select “Preview the report.” Click “Finish”. 

 

 

 

7. Once done, your report will open for preview. Close the preview, and your report will be 
opened in “Design View”. If your report is not automatically opened in “Design View”, 
you can change it under the “Home” tab by clicking “View”  “Design View”. 

 

8. In the report, drag the “Signature” field to make it much smaller, as seen below: 
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9. Once done, click the “Detail” button near the top of the report so it is highlighted in 
black. 

 

 

 

10. Under the “Design” tab, click the “More” arrow in the bottom right corner of the toolbox 
and selecting “ActiveX Controls”. 

 

 

 

11. Select “SigPlus Control” from the list, and click “OK”. 
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12. A SigPlus object will be created and placed in the top-left corner of the “Detail” section 
of the report. Move the new SigPlus object down by the signature fields. 

 

 

 

13. Once the SigPlus object has been placed by the signature fields, right-click on it and 
select “Properties”. 

 

14. Under the “All” tab, change the “Name” section to read “SigPlus2”. 
 

 

 

 

 

 

 

 



  
    

32 www.topazsystems.com Back to Top 

Access Demo How-To Guide 

15. In the “Detail” section of the report, right-click on the lower signature text box, and select 
“Properties”. 

 

 

 

16. Under the “All” tab, change the “Visible” section to read “No”. This way, the ASCII Hex 
SigString will not be shown in the report. Also, verify that the “Name” section reads 
“Signature”. If not, please change it. 
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17. Once formatting has been completed, we will view and copy code for the reports. In the 
left Access menu, click the arrow and select “Reports”. 

 

 

 

18. Right-click on “Roster” under the “Reports” header and select “Design View”. 
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19. Under the “Design” tab, select “View Code”. 

 

  

20. In the window that appears, select “Detail” from the left drop-down menu. 

 
 

21. Highlight and copy the code seen below: 

 

 

22. Return to the Access window, and under the “Reports” header in the left column, right-
click on “Topaz Test Report” and select “Design View”. 
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23. Under the “Design” tab, select “View Code”. 

 

 

24. Paste the code you copied from step 21 into the “Detail_Format” section, as seen 
below. 

 

 

 

25. Click on “File”  “Save” to save your work. 

 

26. To view your report, right-click on the report you created and select “Print Preview”. 
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27. You are now able to view the report complete with signatures. 

 


